Email Deliverability Issues
Incident Report for LawLytics
Resolved
We have identified the small percentage of our Members who are with affected email providers and have reached out individually with the following message. If we identify more affected users, we will reach out an offer support and a temporary workaround. Because this is not affecting the performance of the LawLytics platform, we are going to mark this status as resolved. Here is a version of the message that we sent to affected Members:

-------
We are writing to you as a precautionary notice to let you know we’ve identified your firm as a customer who, because of your email provider, may be temporarily unable to receive emails sent from our system. This issue was brought to our attention by our email partner, SendGrid, which processes the email notices sent from the LawLytics system to our Members when forms are filled out and blog comments are received on their websites.

The issue is that a provider of curated email blacklists erroneously listed one of SendGrid’s IP addresses. Your email provider has been identified as one that subscribes to that blacklist. The result is that some or all emails sent using that IP address may be prevented, by your email provider, from reaching your inbox.

This issue does not affect the functionality of LawLytics, and all forms are and have been working properly. It does mean, however, that you might not receive, or might experience delays in receiving, email notices of form-fills while SendGrid works with the blacklist provider to resolve the issue by having them remove the blacklisted IP address.

We don’t want you to miss notification of form submissions and are therefore recommending that you log into your LawLytics control panel and check your inbox while this issue, which we expect will be resolved soon, is ongoing.

We are working with SendGrid and monitoring the situation and will send updates as they are available. If you are not currently receiving notices and you’d like a temporary solution to make sure that you’re able to receive email notices in the interim, we can help you add a Gmail address to your account so that you can receive form notices there, and then we can remove it at your request when deliverability to your primary email address resumes.

If you have questions or want help with either adding an email address or testing your email provider’s deliverability, or if there’s anything else (related or not) that we can do to help you, please let me know.
Posted Dec 17, 2020 - 19:41 MST
Update
We continue to monitor email notification deliverability reliability. We continue to recommend checking your inbox in the LawLytics control panel. If you are seeing form submissions in your LawLytics inbox that you are not being notified of via email (but are supposed receive via email because that box is checked on the form), please let our support team know.
Posted Dec 17, 2020 - 11:37 MST
Update
We continue to monitor email notification deliverability reliability. We continue to recommend checking your inbox in the LawLytics control panel. If you are seeing form submissions in your LawLytics inbox that you are not being notified of via email (but are supposed receive via email because that box is checked on the form), please let our support team know.
Posted Dec 17, 2020 - 09:06 MST
Update
We continue to monitor email notification deliverability reliability. We continue to recommend checking your inbox in the LawLytics control panel. If you are seeing form submissions in your LawLytics inbox that you are not being notified of via email (but are supposed receive via email because that box is checked on the form), please let our support team know.
Posted Dec 17, 2020 - 04:37 MST
Update
We are continuing to monitor the potential issue and will post additional information as it becomes available. Out of an abundance of caution we recommend that Members check their inboxes in the LawLytics control panel and do not rely on the delivery of email notices until we are able to confirm the resumption of reliable deliverability across the board.
Posted Dec 16, 2020 - 19:27 MST
Monitoring
Our third-party email processor, which is responsible for delivering email notices for form submissions and blog comments has reported a temporary deliverability issue that affects a small number of our customers domains and may cause delays in deliverability.

We are working with the provider as they address the issue and will update the status as information becomes available.

In the meantime, if you are not receiving form submissions through email, we recommend logging into your LawLytics control panel and retrieving the most recent submissions directly in your inbox. No form submissions are being lost, but at this point we are unable to predict how long the transit of the email notifications will be delayed.
Posted Dec 16, 2020 - 16:14 MST
This incident affected: Platform (CMS).